Upgrading

Use this as a reference when upgrading between Mongoid versions. You can always reference the CHANGELOG for bug fixes, new features, and major changes between versions.

Mongoid follows versioning guidelines as outlined by the Semantic Versioning Specification, so you can expect only backwards incompatible changes in major versions.

Upgrading to 3.0

If you are just wanting to generate a new mongoid.yml from scratch, ensure you delete the old one first so you do not get validation errors when initializing the app at generation time.

The following are backwards incompatible changes in this release.